Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
KC868-A16S Paired Inputs
Good Afternoon,

I'm attempting to get my first Kincony KC868-A16S integrated with HA but I'm experiencing a couple of issues. 

1.  The inputs seem to be paired for some reason...?  When I connect to the module using the web browse and short between ground and a single input two inputs turn.  Results below

Short input 1 = Inp1 & Inp9
Short input 2 = Inp2 & Inp10
Short input 3 = Inp3 & Inp11
Short input 4 = Inp4 & Inp12
Short input 5 = Inp5 & Inp13
Short input 6 = Inp6 & Inp14
Short input 7 = Inp7 & Inp15
Short input 8 = Inp8 & Inp16
Short input 9 to 16 = No inputs turn on

KC868-A16S V1.1  Firmware V1.0.15

2.  Using the ESPhome Dashboard to install the configuration fails at "Linking  .pioenvs/kc868-a16s/firmware.elf".  After some time the connection is lost to HA, once it has restarted the device remains offline and the installation is unsuccessful. Get the same result regardless of serial or wireless connection.

HA Version installed on a PI3
  • Core  2024.5.4
  • Supervisor  2024.05.1
  • Operating System12.3
  • Frontend  20240501.1

Any assistance would be appreciated   Smile
1. if you want to use KCS firmware , download at here: , make sure you are downloading "A16S" firmware, not "A16" firmware, they are two different model.
2. here is ESPHome yaml for A16S, you can directly to use:
Hi Admin,

Thanks for the quick reply.

1. New firmware has done the trick

2. Not sure what I'm doing wrong but still can't get the install to complete successfully. The only success I have had is using the ESP Web USB serial "prepare for first use". This makes the device available for to be adopted and I can download default yaml even though I don't get a successful completion, on reboot it is online. If I replace with yaml detailed above it continues to fail at the "Linking .pioenvs/kc868-a16s/firmware.elf". I have tried USB serial and network options and both fail at the same point.

Any ideas what the issue maybe???
do you have installed USB driver firstly? here is download link:
(05-19-2024, 11:54 PM)admin Wrote: do you have installed USB driver firstly?  here is download link:

It might be an issue with my Pi3....?  I just setup on a Pi5 and didn't miss a beat.

Thanks again for the help.
ok, maybe your Pi3 problem, it's too old.

Forum Jump:

Users browsing this thread:
1 Guest(s)